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changes and improvements to the products described in 
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Welcome to Flow Vision™ SC
Flow Vision™ SC is a graphic based software package that allows you to 
operate any Alicat flow or pressure instrument via a graphical user interface. 
Flow Vision™ SC lets you: access information from your Alicat instruments; 
make changes in commands to those instruments; monitor performance; 
log data; chart data; and communicate directly with the unit via a terminal 
window.
If you have used earlier versions of Alicat Scientific’s Flow Vision™ software, 
we are sure you will find many new and improved functions in this latest 
version: Flow Vision™ SC.
Note: Identifiers and scripts from earlier versions of Flow Vision™ are not 
recognzed by Flow Vision™ SC.

System Requirements
• Microsoft® Windows® XP® or Microsoft® VISTA®
• Microsoft® .NET Framework Version 3.0
(A copy of Microsoft® .NET Framework can be downloaded at: 
http://www.microsoft.com/downloads/details.aspx?Familyd=262D25E3-
F589=4842-8157-034D1E7CF3A3&displaylang=en) 
• 18 MB hard disk space
• Available COM port that supports 19200 baud communications*

* Note: Some laptops are not equipped with serial ports. A virtual serial port 
can be created using a USB to Serial adapter.
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Section 1 - Getting Started
In this section you will learn about:

•	 How to install Flow Vision™ SC to your computer
•	 How to start using Flow Vision™ SC

Installing the Software
In order to begin using the Flow Vision™ SC software, you will need to install 
the software onto the computer to which you plan to connect your Alicat flow 
or pressure instrument. 
To install the software, place your original Flow Vision™ SC CD into the CD or 
DVD drive on your computer or laptop. If your computer does not have a CD 
or DVD drive installed, please contact the vendor from whom you purchased 
the computer, the manufacturer of the computer or your company’s computer 
technician.
Once you have placed the CD into the computer’s drive, you should hear some 
noise from the computer’s drive. In a moment, you will see the installation 
screen on your monitor:

To continue, choose the button marked “Next >”. 
Upon clicking “Next” the End User License Agreement will be shown. 
Please read the Agreement carefully and if you agree to the terms listed, use the 
mouse pointer to place a check mark in the box next to the sentence indicating 
that you agree to the End User License Agreement. After you have done that 
you can click the “Next” button to continue with the software installation. If 
you do not agree to the terms listed, cancel the installation, remove the CD 
from your computer and contact your software vendor to arrange returning the 
software for a refund. 
You can abort the installation at any time by choosing the button marked 
“Cancel” or revert to the previous step by choosing the button marked “Back”.
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The next screen will ask into which directory you would like to install the Flow 
Vision™ SC software. 

By default, the program will create a program folder and subfolder in the 
“Program Files” folder in your main drive directory. This location is suitable 
for most users. If you would like to install Flow Vision™ SC into a different 
location, you can manually enter the location’s address in the space provided 
or you can choose the button marked “Browse” and select the appropriate 
directory. 
If you are using a computer at your company and are unsure of the appropriate 
location for installation, please request assistance from your company’s IT 
department.
You can review the amount of space required on your computer to install Flow 
Vision™ SC by choosing the button marked “Disk Cost”. 
A window will appear showing available drives in the computer, the size of 
each drive, how much space is available on each drive, the space required for 
Flow Vision™ SC, and the amount of space that will be available after Flow 
Vision™ SC is installed. 
This allows you to select the most appropriate location for Flow Vision™ SC 
to be installed based on drive space constraints. 
To exit this screen and continue with the installation process, select the button 
marked “OK”.
You will also be asked if you would like to install Flow Vision™ SC for yourself 
only or for anyone who uses the computer. Flow Vision™ SC’s operation 
will not be affected in any way by this selection. Once you have made your 
selections, click the button marked “Next”.
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The following screen will inform you that Flow Vision™ SC is ready to be 
installed. You can take this opportunity to go back and make changes or to 
cancel the installation.

If you are satisfied with your choices, you can continue with the installation by 
choosing the button marked “Next”.

You will not see an installation screen with a progress bar visually indicating 
the progress of the installation of Flow Vision™ SC onto your computer. 
Do not turn off or restart the computer during the installation process. 
Turning off or restarting the computer during this process will cause Flow 
Vision™ SC to not install properly and possibly cause damage to your 
computer.
When the installation process is complete, a screen will appear indicating that 
Flow Vision™ SC has been successfully installed on your computer. To exit 
this screen and the Flow Vision™ SC installation process, select the button 
marked “Close”.

Once you have selected “Close”, the installation screen will disappear from 
your screen. 
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You can now remove the Flow Vision™ SC CD from your computer. You will no 
longer need the Flow Vision™ SC CD to run the software. 
Be sure to keep the Flow Vision™ SC CD and the case with the Registration 
Key Label in a safe place in the event you need to reinstall the software.
Launching Flow Vision™ SC
With Flow Vision™ SC installed to your computer, you can now begin using the 
Flow Vision™ SC program.
In order to begin you must first start the program. 
To start the program you will need to select the Flow Vision™ SC program 
shortcut from the Start Menu.
>>Start Menu>Alicat Scientific>Flow Vision

Once you have selected the Flow Vision™ SC shortcut from the Start Menu, 
the program will begin.
After registration, the application will gather information about your system. 
Specifically, Flow Vision™ SC probes your computer for available COM ports. 
This process only occurs on the first launch of Flow Vision™ SC. All subsequent 
launches will load more quickly.
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Section 2 - Setting up Flow Vision™ SC
In this section you will learn about:

•	 Registering Flow Vision™ SC
•	 Flow Vision™ SC Menu and Menu functions
•	 Flow Vision™ SC screen layout

Registering Flow Vision™ SC
Before Flow Vision™ SC will launch, it needs to be registered. A registration 
key label is affixed to the CD case in which the FlowVision™ SC CD is 
stored.
Please enter the name and registration key from the registration key label in 
the appropriate fields. After successful registration, the application will launch.

Flow Vision™ SC Menu and Menu functions
When you start Flow Vision™ SC for the first time you will see this screen:

Along the top of the screen you will find the menu functions: File; Edit; Polling; 
View; Window; Macros and Help. 
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To access a menu, place your mouse cursor over the desired menu and click 
the left mouse button. 
To select a function from the menu point the mouse arrow to the desired 
function and once it is highlighted, click the left mouse key. 
Explanations of each menu and its sub-functions follow.
File Menu
The file menu allows you to exit the program.

Edit Menu
The edit menu allows you to access the “Properties” section of Flow Vision™ SC. 
In this section, you can make changes as to how Flow Vision™ SC functions.

The polling rate is the time interval for the software to take data from the 
instrument, measured in milliseconds. 
Increasing the polling rate (lengthening the time interval) will reduce the 
frequency at which data is taken from the instrument by the software. 
Conversely, decreasing the polling rate (shortening the time interval) will 
increase the frequency at which data is taken from the instrument by the 
software.
The “View trace/debug information” option will allow you to view in-depth 
information about the application. 
The options on the “Appearance” tab allow you to modify the way Flow Vision™ 
SC looks, including background color and image. 
The “Updates” tab is used to modify the Flow Vision™ SC updating settings. 
You can disable automatic updates on this tab.
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Polling Menu
Polling is the term used to describe communicating with the instrument. The 
Polling Menu will allow you to initialize or terminate polling via the software. 
To initialize polling select “Start Polling” > “All” and to terminate polling select 
“Stop Polling” > “All”.
View Menu
The View Menu allows you to choose how the main screen will appear when 
you start the program. Flow Vision™ SC is a modular program and each 
function of the software is represented by a module. The View Menu lets you 
select which modules will be available when the program starts. Modules are 
explained in detail later in this manual.
The View Menu also allows you to save variations of screen layouts in the event 
multiple users have different preferences or you have different requirements 
at different times. You can save and load modules as you require via the View 
Menu.
Window Menu
The Window Menu allows you to arrange open windows in a specific way. The 
formats are Cascade, Tile Horizontally, Tile Vertically and Icon.
Macro Menu
The Macro Menu allows you to store groups of windows that are launched 
together. Saved window macros are launched through the Macro Menu item. 

Help Menu
The Help Menu contains documentation that will answer questions about 
the software and how it is used. You can access Flow Vision™ SC version 
information by selecting the “About” tab.
The “Register” tab will allow you to enter a CD Key if your CD Key has been 
compromised or if you receive a new CD Key from the software vendor.
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Flow Vision™ SC Screen Layout
Flow Vision™ SC allows you several options in screen configuration. Flow 
Vision™ SC is a modular program. Some people will use more functionality 
than others. As such, components of Flow Vision™ SC have been housed in 
separate modules. Modules and their functions will be discussed later in this 
manual.
Tabs
When Flow Vision™ SC is started for the first time, you will see a column of 
tabs along the left side of the Flow Vision™ SC window.

Placing your mouse cursor over an individual tab will open the tab into the 
main screen. Removing your cursor from the tab window for a few seconds will 
cause the tab to disappear from the main screen. 
If you would like the tab to stay open permanently, simply press the auto-hide 
(push-pin shaped) button located on the upper right corner of the tab screen. 

If the pin is facing to the left the tab window will disappear when not in use. If 
the pin is facing downward the tab window will stay open until the auto-hide 
button is pressed again. 
The auto-hide is useful when performing multiple functions. Non-critical 
functions can be hidden while the critical functions are pinned to the screen.
Flow Vision™ SC allows you to choose which modules are visible and which 
are not. 

Devices

Scripts

Data Logs

Charts

Terminals
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By using the using the View>Modules menu, you can select which module 
tabs are made available. By default, all module functions are shown as tabs. 
Use your mouse button to uncheck the modules you do not want shown. 
If you decide you want to use a module that is not visible, simply return to the 
View>Modules menu and use your mouse button to check the module you 
would like to have visible.
Based on the size of the Flow Vision™ SC window, you may not see all of the 
available options in a particular module tab. 
If the window is too small to list all of the options, you will see a downward 
facing arrow to the right of the visible options. Clicking this arrow will display 
the remaining options. If the window is wide enough, you will see all of the 
available options and the downward arrow will not be visible.
Moving and Docking Modules in the Flow Vision™ Window
Another innovative feature of Flow Vision™ SC is the ability to move and dock 
modules to different locations on the screen. 
To move a tab menu you will first need to turn off the auto-hide function by 
using your mouse to press the auto-hide button. (See ‘Tabs’ section, page 13, 
for instructions). 
Drag the open window towards the part of the screen in which you like it to 
stay. The following diagram will appear on the screen:
Drag the window to one of the anchor points and the window will reattach itself 
to the screen. 

You can also re-activate the auto-hide feature and a tab will be created on the 
side of screen on which the window is attached.
You may repeat this procedure for any number of tabs. By using the center 
anchors you can arrange tabs side-by-side or bottom-to-top, in order to 
maximize open tab arrangement on the screen.
Individual screen layouts can be saved via the View>Layout menu.
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Section 3 - Communicating with a Device

In this section you will learn about:
•	 Connecting and registering an Alicat Scientific device
•	 Opening the Device Module
•	 Polling a device
•	 Locking the front display
•	 Changing the measured gas
•	 Changing averaging
•	 Taring the unit
•	 Set-point control (controllers only)
•	 Valve tuning (controllers only)
•	 Getting information about the instrument
•	 Removing devices
•	 Setting software alarms
•	 Creating custom modifiers

Connecting To An Instrument And Receiving Data
In order to start using Flow Vision™ SC with an instrument, you will need to 
add the instrument to Flow Vision™ SC’s device module. 
There are two ways to add devices to Flow Vision™ SC. The “Add” option 
allows you to add a single device on a known COM port. If you have multiple 
devices or you are not sure which port your device is connected to the “Search” 
option is a better choice. 
Adding a device on a known COM Port
If you have not connected your instrument to your computer you will need to 
do this before taking the next step. You can connect an Alicat instrument to a 
computer using Alicat accessory cable MD8DB9 or by following the directions 
in the Alicat instrument manual about how to make a cable.
With your device connected to your computer and powered up, open the 
“Devices” tab and select “Add”. 
A window will appear entitled “New Device”.
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Use the arrow to the right of the blank space entitled “COM Port:” to select 
the com port to which your device is attached. By default your unit will come 
with the unit identifier A. (For information on unit identifiers please consult the 
product manual that accompanied your Alicat instrument). 
If your unit identifier is not A, select the appropriate identifier. 
Once the proper selections have been made, select “Find Device >” and Flow 
Vision™ SC will look for the attached instrument. The process make take a few 
moments. A successfully added a device will be visible in the Devices tab.
Searching for Devices
To search for devices connected to your computer choose the “Search” option 
from the “Devices” menu.
Note: If you do not see the “Search” option in the “Devices” menu click the 
down arrow for more options.

After selecting the option, the “Search for Devices” window will open.

Select the number of devices connected to your system. After Flow Vision™ 
SC finds this number of devices it will stop searching. 
The “COM ports” box lists the available ports on your system. Ports that Flow 
Vision™ SC determines may have devices connected are checked. 
Check any other ports you would like to search. 
Finally, choose the range of identifiers you would like to check for. Click the 
“Search >>” button. 
Flow Vision™ SC will locate and load devices matching the selected 
parameters. Once you have successfully added a device, it will be visible in 
the Devices tab.
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Opening the Device Window
After you have successfully connected to your instrument, from the Device 
tab double click on the device you would like to monitor. After a few moments 
a window will appear showing a virtual image of your device with a functional 
display. 
With the device window open, you will see a row of tabs across the top of the 
window underneath the window header. 

The tabs are: Display; General; Control; Info.
Each of these tabs allows you to make functional changes to the instrument. 
Display Tab
The display tab is the default starting tab when opening the device window. In 
this tab you will see a virtual representation of an instrument. 
The image is generic and may not look exactly like the unit connected, this is 
normal.

 
You will immediately notice the display screen. This screen is a representation 
of the display functions on the instrument. You can access display functions by 
rolling your mouse over and pressing any of the buttons on the virtual screen.
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Using the buttons on the Flow Vision™ SC virtual display will not make the 
same change to the display on the instrument itself.
You will notice that the menu screen available on the instrument display is not 
available on the Flow Vision™ SC virtual display, this is normal.
General Tab
The General tab is where you will make changes affecting the unit’s operation. 
In this tab you will find the gas select menu, flow tare, display lock and 
averaging functions.

Gas Select™ — To change the measured gas type, simply click the down 
arrow to the right of the gas name to display the gas list. 
Scroll down the list until you see the gas you will be flowing and click on that 
gas. The selected gas should be displayed in the white box. If it is not, repeat 
the steps. 
If you do not see the gas you will be flowing on the list, please contact the 
factory before proceeding to verify if your unit is compatible with the gas. 

Do Not Flow Gases That Are Not On The Gas List Without Factory 
Approval. Doing So Will Void Your Warranty And May Cause Permanent 

Damage To Your Flow Instrument.
Averaging changes the sensitivity of the unit’s display to reduce “jitter”. 
Averaging does not change Flow Vision™ SC’s data.
When the averaging is set to a low figure, the unit’s display will show flow rate 
changes to the last significant digit as it is happening. The result is a rapidly 
changing integer to the right of the decimal. Some users find this to be a 
nuisance when trying to record data. 
By increasing the averaging, the display will stabilize and not show the minute 
changes in flow. Increasing averaging will not affect the performance or 
accuracy of the unit in any way. Averaging is simply a setting that helps reduce 
the “jitter” of the display.
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Tare — The tare function is used to set the zero on the instrument. Tare only 
when there is no gas flow going to the unit. The tare function is discussed in 
detail in the instruction manual that accompanied your instrument. 
Control Tab (Controllers only)
The control tab allows you to change set-point and perform valve tuning on 
your controllers.

To change the set-point simply enter the desired set-point in the text box. 
Once the set-point number is in the box, click the mouse on the “Set” button 
to send the set-point to the instrument. The unit should now be flowing the 
process gas at the desired set-point.
Control Loop — You can change the control loop if your process requires. 
By clicking the down arrow in the box to the right of “Close Loop”, you can 
select to close loop on mass flow, volumetric flow or pressure. 
With MC/MCP/MCR series mass flow controllers,you can select to close loop 
on mass flow, volumetric flow or pressure, while pressure controllers will allow 
you to close loop on pressure and liquid controllers will allow close loop on 
volumetric flow.
Once the desired control loop has been selected, click on the “Set” button to 
send the command to the flow instrument. 



20

Valve Tuning — If you require specialized valve tuning, you may do this via 
the “Control” section in the “Advanced” section. 
Adjustment of PD&I values will change how the valve responds, valve stability 
and valve speed. 
It is strongly recommended that adjustments to PD&I settings not be made 
unless you have some experience with proportional valve tuning. 

Adjusting The PD&I Settings Without Prior Training May Result In 
Permanent Damage To Your Control Valve.

Valve offset or preload is a setting to compensate for the mechanical pressure 
effects that gas pressure may exert on the control valve. Gas pressure in the 
system exerts a mechanical force on the control valve that, depending upon 
the gas pressure, may slow its response when opening. 
By increasing valve offset, a signal is sent to the valve that will increase its 
force when opening. 
Adjusting valve offset may help your Alicat controller respond more quickly 
when moving away from a zero set-point.
Valve offset is a value between 0 and 100, 0 being little to no offset and 100 
being maximum offset. 
If your controller uses an Alicat medium sized valve, the offset effect is reversed. 
0 being maximum offset and 100 being little to no offset.
Valve offset has no effect at a zero set-point.
Info Tab
The info tab provides specific information about the unit. 
This information is helpful when requesting telephone support or authorization 
for recalibration or repair.
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Polling a Device
To poll a device choose the “Polling > Start Polling > All” option from the main 
menu. Alternately, you can press Ctrl + P on your keyboard. The device will 
begin polling at the rate selected in the “Properties” window. All process that 
display/use device data (device windows, data logs, charts, etc.) will start 
updating. To stop polling, choose the “Polling > Stop Polling > All” option from 
the main menu or press Ctrl + Alt + P on your keyboard.
Removing a Device
To remove a device, select the desired device in the “Devices” tab by clicking 
it once. After selecting the device click the “Remove” option in the menu. 
After selecting “Yes” at the prompt the instrument will be removed from Flow 
Vision™ SC.

Removing A Device That Is Used In a Data Log/Chart Will Cause 
That Data Log/Chart To Stop Working.

Setting Software Alarms
The “Modify” button will activate a window from which you may review 
information about the device, set software alarms and/or modify any of the 
measured parameters.

To create a software alarm, use your mouse to check the “Enabled” box on 
the “Low Alarm” and/or “High Alarm” checkbox. Once enabled you will be able 
to enter a number in the “Value:” box. This value should reflect the point at 
which you would like the alarm to initiate. You will see that there is a tab for 
each measured parameter in the “Modify” window. An alarm can be set for 
any available measured parameter by entering those values into the properly 
corresponding section. 
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When an alarm is activated you will hear a tone from your computer (speakers 
are required for tone warning) and the virtual display will change from the 
normal green to the color you have selected for the alarm type. 
If you have an alarm set please be sure to keep the virtual display window 
open.
PLEASE NOTE: The alarm function in Flow Vision™ SC is done via the 
software only and does not activate any kind of alarm on the device itself. 
If an alarm is triggered the device will continue to operate. 
A technician must make changes to the device either directly or through 
the Flow Vision™ SC software. Also, in order for the alarm to function, 
Flow Vision™ SC must be running and the monitored device must be 
communicating with Flow Vision™ SC.

Creating Custom Modifiers
Custom modifiers can be used to change the value and heading for any 
measured parameter. 
For example, temperature is measured in degrees Celsius by the device and in 
turn is displayed as such. Using Flow Vision™ SC, you can change the value 
and heading of the measured parameter using the Custom Modifier field. 
We want to change the temperature display from degrees C to degrees F. 
To do this, check the “Enabled” box under “Custom Modifier” in the tab 
corresponding to the measured parameter you want to modify. 
Next, in the space next to “Custom Units:” type the heading that you would 
want to use, for this example it would “˚F”. 
In the space next to “Custom Expression” you will enter the formula used to 
convert the measured parameter into your desired measurement. 
In this case we will the formula (˚C * 9/5) + 32 as the conversion. The word 
“value” is used to define the measured parameter. So, the formula for converting 
˚C to ˚F will look like this: “(value * 9/5) + 32” without the quotes. 
Once you have entered the conversion expression and the units you can test 
the functionality of the expression before applying it. 
To do that, enter a number in the box to the right of “Value” and then click the 
“Text Expression” button. If your formula is correct the window that appears 
will show the correct integer based on your formula. 
In this case we use 2 as the test value and receive a test expression of 35.6. 
This means our formula is working. 
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Section 4 – Optional Modules
Flow Vision™ SC, as mentioned earlier, is built around the concept of modules. 
As such, you can now add or remove modules based on your intended level 
of use. 
For the casual user only the most essential modules can be made available and 
the others made invisible — reducing screen clutter and possible confusion. 
For the advanced user, all modules can be made visible and available on the 
screen.
In this section, we will go over each of the modules and their functionality.

Data Logs
Data logs can be created if you are required to keep records of measured data 
for the device for any period of time. Data logs are useful because they can be 
viewed outside of Flow Vision™ SC or incorporated into a database to create 
an accurate history of data given by the device.
To create a data log, you will first need to access the “Data Logs” module. If 
you cannot see the Data Logs module please refer to section 2 (page 11).
Once you have accessed the Data Logs module click on “Add”. A window will 
appear with options for configuring your data log.
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First, name the data log. This is done by entering a name into the text box to 
the right of “Log Name:”. 
Next, using the drop down arrow next to the “File Type:” indicator, select the 
type of log file you would like.
After you have selected the log name and the type of log file, you will need 
to tell Flow Vision™ SC where you would like to save the file and under what 
name.
Next, define the unit (data source) and the parameters you want to log. To do 
this, click the “Data” tab on the top of the New Log window.

Define a data source by clicking the arrow on the right side of “Device:” in the 
“New Data Source” section on the bottom portion of the window. Choose the 
device from which you will be logging data.
In the “Parameter” section, place check marks next to the parameters you wish 
to log.
Note: Not all parameters are applicable to all Alicat devices.
Finally, click the “Add Source” button and the device, along with the selected 
parameters, will appear on the top portion of the window.
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Splitting Data Files
If you are logging to a .txt file or a .csv file, you can have Flow Vision™ SC split 
the file into smaller pieces so that the data is more manageable. 
Data can be split by file size, by time or by a predefined schedule selected by 
the user.

Please note: When database file extensions are selected, the File Splitting 
menu will be inaccessible. Database files are handled by external programs 
that are not affected by file size and have interfaces that allow users to 
manipulate data through the database program itself.

Starting and Stopping Data Logs
Flow Vision™ SC also allows you to configure how data logs are started and 
stopped. 
To access this functionality, select the “Start/Stop” tab at the top of the New 
Log window.
Logs can be set to start: manually; when Flow Vision™ SC starts; after an 
alarm is triggered; or by a user defined schedule. 
Click the round button next to how you would like the logging to start and/or 
stop and fill in any necessary blanks.
Once you have completed all of the sections for a new log, click the “Save” 
button in the bottom right hand corner to save the log file. 
When the log file has been successfully saved, the New Log window will 
automatically close.
By accessing the Data Logs module again, you will see your saved test in the 
window.
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If you chose to start or stop the data log manually, you can do so by selecting 
the log you want to run from the window and clicking the Start/Stop button in 
the Data Logs module window.
Once you have completed the data log, you can recover the file using the 
Open Folder button in the Data Logs module window.
By accessing the Data Logs module again, you will see your saved test in the 
window.
If you chose to start or stop the data log manually, you can do so by selecting 
the log you want to run from the window and clicking the Start/Stop button in 
the Data Logs module window.

Once you have completed the data log, you can recover the file using the 
Open Folder button in the Data Logs module window.
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Charts
Flow Vision™ SC allows you to create charts to display data.
Creating Charts
To create a chart, access the Charts module. If you do not see the Charts 
module refer to section 2 (page 11) for instruction on how to make the Charts 
module visible.
Once you have accessed the Charts module, click on the “Add” button to bring 
up the “New Chart” window.

In the New Chart window, begin by naming the chart. To do this, type a name 
for the chart in the space provided to the right of “Chart Title:”. 
Now select the type of chart you would like. This is done by using the down 
arrow to the right of “Chart Type”. 
The available chart choices are: Spline; Line; or Column.
Next, you will need to add a device or series to the chart. 
To do this, select the device to chart by using the down arrow to the right of 
the “Device” field. 
The arrow will display a list of available devices from which to select one.
Finally, select the parameter you would like to chart. 
Clicking the down arrow to the right of the “Parameter” field will display a list of 
available parameters from which to select. 
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Once you have selected a parameter, assign it a color using the “Color” field 
below the parameter field. 
Again, click the down arrow to the right of the “Color” field to display a list of 
available colors from which to select.
With the color selected, press the “Add Series” button to add the parameter to 
the “Series” section of the New Chart window.
Each series represents a charted line. You can repeat the “New Series” step 
for as many parameters you would like to chart from as any units you have 
connected.
You will notice that the color of the text defining the charted parameter in the 
series field will correspond to the color of its line on the chart.
A series can be removed by placing a check mark in the box next to the series 
name in the Series field and pressing the “Remove Selected” button.
Once satisfied with your selections, press the “Add Chart” button to add the 
chart to the list of available charts in the Chart module. 
After you have added the chart, the New Chart window will disappear from 
your screen.
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Charting
To begin charting, access the Chart module to see your chart in the list of 
available charts. 
Double click on your chart and it will bring up a window charting your selected 
series.

Charting is done based on units of time in seconds. The Y axis will scale 
according to the parameter with the largest integer measurement. In this case, 
it is temperature.
Please note: You cannot save/export a chart setting. Once the chart is removed 
from the Chart module, it will need to be redone if you would like to chart the 
same series.
The Chart module will allow you to modify an existing chart using the “Modify” 
button or to delete an existing chart by using the “Remove” button. 
You can also “Refresh” the list if a previously added chart does not appear on 
the list.
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Scripts
Scripts allow users to create automated command sets based on time. You 
can program Flow Vision™ SC to send specific commands to your connected 
flow instruments at specified time intervals.
To create a script, you will first need to access the Script module tab. If you do 
not see the Script module refer to section 2 (page 11) for instruction on how to 
make the Script module visible.
Once you have accessed the Script module, click “Add” to bring up the New 
Script window. 
At the top of the window, in the box to the right of “Script Name”, name the 
script you are building. You can name the script anything you would like.
To the left of the device for which you would like to add a command, press the 
“+” symbol to display a list of available commands. 
Add a command by either double-clicking on the desired command or clicking 
and dragging the command into the box on the right half of the screen.
After you have double-clicked or dragged a command, an Input window will 
appear in which you will fill in the blanks with your desired values. 
Note: The common value among all the script functions is Execution Time. 
The Execution Time is the time (in seconds) at which the address change 
should take place from the start of the script. 
Once you have populated the Parameter Values, simply click the “Add 
Command” button to add the command to the script. 
If you require the script to run in a loop, you can select the number of loops to 
run and the time between each loop in the Options tab.
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Descriptions of Simple Script Commands
Write Address 
The Write Address command allows you to write a value to a register address 
of the instrument. You are required to enter Execution Time, Address Code 
and Address Value. The Address Code is the actual address to be changed, 
while the Address Value is the value for the register. 
Please note: Written register values are not easily undone. You must rewrite 
the original value to the register if you want to undo your changes. 
Please use this function only if you are sure you need to do so and only 
after recording the original register value. If you are unfamiliar with register 
values and their corresponding functions, please contact Alicat or your local 
distributor for information.

Change Set-point (Scale Units)
The Change Set-point (Scale Units) command lets you change the set-point 
of the instrument as a function of the unit’s scale. Selecting this command will 
cause an Input window to appear that requires input of Execution Time (in 
seconds) and Scale Units.
Please note: The Change Set-point (Scale Units) function is only available 
with controllers.

Change Set-point (% of Full Scale)
The Change Set-point (% of Full Scale) command allows you to change the 
set-point of the instrument as a function of percentage (0 ‑ 100%). Selecting 
this command will cause an Input window to appear that requires input of 
Execution Time (in seconds) and % of Full Scale. It is not necessary to use the 
“%” symbol when populating the Parameter Value.
Please note: The Change Set-point (% of Full Scale) function is only available 
with controllers.

Tare
The tare function is used to set the zero on the instrument. Tare only when 
there is no gas flow going to the unit. The tare function is discussed in detail in 
the instruction manual that accompanied your instrument. Choosing the tare 
function will cause an Input window to appear that requires input of Execution 
Time (in seconds).

Reset Total
The Reset Total function is used to reset the instrument’s flow totalizer. 
Choosing the Reset Total function will cause an Input window to appear that 
will require input of Execution Time.
Please note: The Reset Total function is available only for instruments ordered 
with the optional totalizer.
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Sample Script
Below is a sample script that will cause a flow controller to:

1.  Change the set-point to 0 at .1 seconds from start (controllers only)
2.  Tare at .3 seconds from start
3.  Reset the flow totalizer at .5 seconds from start (devices with totalizer 
      only) 
4.  Change the set-point to 25% at 1 seconds from start (controllers only)
5.  Change the set-point to 10SLPM at 2 seconds from start (controllers 
      only)
6.  Change the set-point to 15SLPM at 3 seconds from start (controllers  
      only)
7.  Change the set-point to 100% at 4 seconds from start (controllers only)

Once you have completed a script, you can review your selections. If you 
decide you don’t want particular steps, they can be removed by selecting the 
specific step(s) and then clicking the “Remove Selected” button. 
Finally, click the “Save” button to save the script into the Script module tab.
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Running the Script
To run the script, access the Script module tab and double-click the script you 
would like to run. 
In this example, it is the script that was just saved. 
Once you have double-clicked on the script, a window will appear that will 
allow you to run the script and monitor the results of each command.

Click the “Run” button to run the script. In the Output box on the bottom half of 
the screen, you will see a verification of each function as it takes place.
At the end of the script, the instrument will remain as it was after the last 
command in the script.
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Advanced View Tab – Building Advanced Scripts
Flow Vision™ SC includes a complex script building system that is based on 
the C Sharp (C#) programming language. 
While the majority of users will find that the Simple View will offer all of the 
flexibility they require, users who are familiar with C# can use the Advanced 
View tab to create complex scripts with nearly limitless functionality.

If you intend to use the Advanced Tab, you must be familiar with C# 
programming language. Please do not attempt to use this feature 

without C# experience and knowledge.
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Terminals
The Terminals module allows communication with the device through an ASCII 
terminal without leaving the Flow Vision™ SC program.
To begin a terminal session, you will need to open the Terminal module tab. 
If you do not see the Terminal module tab refer to section 2 (page 11) for 
instruction on how to make the Terminal module visible.
Upon accessing the Terminal module tab, you will see the communication port 
to which your unit is attached. 
Before beginning a terminal session, make sure that Flow Vision™ SC is not 
polling the connected instrument(s). If the program is polling, you will see 
polled data on the terminal window.
Begin the terminal session by double clicking on the communication port to 
which the instrument you would like to poll is connected. 
A window will appear that will allow you to communicate with the instrument as 
you would via a terminal window.
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Please refer to the instruction manual that accompanied your instrument for 
instructions on communicating with a unit via a terminal window. 
You will not have to worry about connection settings as this is done through 
Flow Vision™ SC if the device has been identified by Flow Vision™ SC as a 
connected and available device.

Uninstalling Flow Vision™ SC
To uninstall Flow Vision™ SC use the Add and Remove Programs function 
from your Windows® control panel. Flow Vision™ SC can be selected from the 
program group and uninstalled. If you are unfamiliar with the Add and Remove 
Programs function of your Windows® software please consult your system 
administrator or refer to your Windows® operating manual.
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Troubleshooting and FAQs

If you have Flow Vision™ SC installed and running, the Help Menu (page 12)
may provide the answer you are looking for. 

My Alicat device will not connect to Flow Vision™ SC.
1.   Check all connections between Alicat device and computer.
2.	 Make sure Alicat unit is powered.
3.	 Make sure Alicat unit communication is set to 19,200 baud.
4.	 Verify that the communication cable is built correctly and installed 

properly.
5.	 Verify that a connection can be made with the computer using Windows® 

HyperTerminal® and following the instructions in the manual that 
accompanied your flow device. 

Flow Vision™ SC will not start when I put the CD into my CD/DVD drive.
Your computer may not be able to run the autorun script. Try to run the Flow 
Vision™ SC setup.exe program from the drive directory using Windows® 
Explorer®

Flow Vision™ SC will not install properly.
1.	 Verify that your computer meets the minimum requirements to run Flow 

Vision™ SC.
2.	 If your computer meets the requirements and the problem persists please 

contact Alicat directly for support.
The process information displayed on my Alicat device and on the Flow 
Vision™ SC screen don’t always match.
In the configure menu the polling rate will dictate how often the Flow Vision™ 
SC screen is updated. 

Flow Vision™ SC and the display on my Alicat device don’t always 
match at zero flow. 
The Alicat flow device comes with programming to help stabilize the display 
at zero flow. The Flow Vision™ SC display will not have this stabilization 
feature and will show minute fluctuations at zero, while the device’s display 
will be a solid zero. This slight difference in reading is normal.

I can’t find my captured flow data.
Click on the Script. Choose open folder.
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Contact Information
For more information regarding this or any Alicat product, please contact:

Alicat Scientific, Inc
2045 N. Forbes Blvd. Bldg. 103

Tucson, Arizona 85745
USA

Ph: 520-290-6060
  888-290-6060

Fax: 520-290-0109
email: info@alicatscientific.com

Web site: www.alicatscientific.com

Notice: Alicat Scientific, Inc. reserves the right to make any changes and 
improvements to the products described in this manual at any time and without 
notice. This manual is copyrighted. This document may not, in whole or in part, 
be copied, reproduced, translated, or converted to any electronic medium or 
machine readable form, for commercial purposes, without prior written consent 
from the copyright holder.
Note: Although we provide assistance on Alicat Scientific products both 
personally and through our literature, it is the complete responsibility of the 
user to determine the suitability of any product to their application.
The manufacturer does not warrant or assume responsibility for the use of its 
products in life support applications or systems.
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